The iMOW® robotic mower fails to mow when the "Start mowing" or "Start time-delayed mowing" commands are activated. What can I do?

Last update:
1/12/2021
Note: Before you prepare your STIHL product for use, put it into operation, clean, transport, store, maintain, repair, troubleshoot or dispose of it, please read the instruction manual carefully. The instruction manual contains safety instructions and supports you in using your STIHL product in a safe and environmentally friendly manner over a long service life.

Possible cause:

  • Insufficient battery charge
  • Rain detected
  • Flap not closed or not present
  • Message is active
  • Homecall activated on the docking station


Remedy:

  • Charge the battery
  • Setting the rain sensor
  • Close the flap
  • Rectify displayed fault and confirm the message with "OK"
  • End Homecall or repeat command following docking

 

 

GENERAL INFORMATION

How can we help?